Slackware 13: OpenOffice 3.1.1, Digikam, Inkscape, Tora e Google Gadgets !

Sapete già che sono passato a Slack 13. Mi sono trovato, però a dover aggiungere i miei programmi preferiti e siccome ho avuto qualche difficoltà nel compilarli ed usarli, ecco qualche dritta per risparmiarvi il tempo che ho già sprecato io.

OpenOffice 3.1.1

La soluzione più facile, veloce e pratica è usare SlackBuild. Da una consolle seguite questi semplici passaggi:

wget -c http://slackbuilds.org/slackbuilds/13.0/office/openoffice.org.tar.gz
tar -xzf openoffice.org.tar.gz
cd openoffice.org
wget -c http://ooo.mirror.garr.it/mirrors/openoffice/localized/it/3.1.1/OOo_3.1.1_LinuxIntel_install_it.tar.gz
OOLANG=it OUTPUT=/tmp ./openoffice.org.SlackBuild
upgradepkg –install-new openoffice.org-3.1.1_it-i586-1_SBo.tgz

Digikam

Prima di tutto installiamo i kipi-plugins assicurandosi che l’installazione avvenga in /usr e non in /usr/local. Personalmente ho modificato il file CMakeCache.txt ed ho cercato “local”, trovando la linea che definisce il path di installazione. Stessa cosa per Digikam: se non installate il tutto in /usr il programma parte ma non riuscuirete a visualizzare nessuna immagine !

Inkscape

Questo splendido programma per la grafica vettotriale richiede alcune librerie del progetto gnome. Queste librerie richiedono dipendenze “strane” percui, per evitarmi decine di esperimenti sulle svariate combinazioni (che ho provato) ecco quello che dovete scaricate, configurare e compilare:

gsl-1.13

cairomm-1.4.0

pangomm-2.13.8

glibmm-2.18.2

gtkmm-2.14.5

inkscape-0.47pre4

Tora

Se dovete lavorare con i database (MySQL, Oracle, Postgres) Tora è una delle interfacce free più complete che esistono. Nasce come clone libero di Toad (della Quest) e la compilazione, anche se non richiede particolari accorgimenti, può essere problematica. Iniziamo scaricando il client InstantClient 10.2.0.4:

InstantClient 10.2.0.4 Base

InstantClient 10.2.0.4 SQL*Plus

InstantClient 10.2.0.4 ODBC

scompattiamo il tutto dentro /usr/lib/oracle/10.2.0.4. Adesso dobbiamo prendere QScintilla2:

QScintilla-gpl-2.4

e lo compiliamo seguendo le istruzioni:

cd Qt4
qmake qscintilla.pro
make
make install

Poi passiamo a Tora, scaricando i sorgenti dell’ultima stabile (2.1.1):

tora-2.1.1

e configuriamolo:

./configure –with-oracle-libraries=/usr/lib/oracle/10.2.0.4/ –with-oci-version=10.2.0.4.0 –with-qt-includes=/usr/lib/qt/include/ –with-qscintilla-libraries=/usr/lib/qt/lib/

prima di make dobbiamo scommentare una riga nel file src/otl/otlv4.h, altrimenti otterremo errori di compilazione:

// Uncomment the following line in order to include the OTL for
// Oracle 10g Release 2:
//#define OTL_ORA10G_R2  // Togliere il commento a QUESTA RIGA !

dopodichè procediamo alla classica compilazione con:

make
make install

Google Gadgets

Ebbene si, potete avere i fantastici Google Gadgets sul Vs desktop Plasma ! Iniziamo scaricando il pacchetto dei sorgenti:

google-gadgets-for-linux-0.11.1.tar.bz2

poi scompattate il pacchetto, configurate,compilate ed installate:

./configure –prefix=/usr –disable-werror –with-browser-plugins-dir=/usr/lib/xulrunner-addons/plugins
make
make install

Poi lanciate, premendo F2, il comando ggl-qt e….buon divertimento !!!

Nella speranza di esservi stato di aiuto, vi auguro buona fortuna !!!

P.S. NON inviatemi mail se avete bisogno di aiuto: non risponderò a messaggi privati ! Lasciate un commento su questo post, in modo che l’aiuto che potrò darvi sia di beneficio per tutta la comunità. Grazie.


(Visitato in totale 1 volte, oggi 1 visite)
4 comments
  1. Utilissimo il post per OpenOffice però l'ultimo comando è sbagliato, quello corretto è questo:
    upgradepkg –install-new ../openoffice.org-3.1.1_it-i586-1_SBo.tgz

    per il resto tutto ok!
    ciao!

  2. Ringraziandoti per aver messo a disposizione le tue esperienze ti chiedo aiuto riguardo il seguente errore ottentuto al termine della compilazione di TOra. Ho eseguito tutti i passi da te descritti per la compilazione e installazione, tranne che l’installazione di qscintilla che era già installata, ma purtroppo la compilazione è terminata con il seguente errore che non sono in grado di decifrare:

    tora-toawr.o: In function `~toAWR’:
    /appo/tora-2.1.3/src/toawr.cpp:381: undefined reference to `vtable for toAWR’
    /appo/tora-2.1.3/src/toawr.cpp:381: undefined reference to `vtable for toAWR’
    /appo/tora-2.1.3/src/toawr.cpp:381: undefined reference to `vtable for toAWR’
    /appo/tora-2.1.3/src/toawr.cpp:381: undefined reference to `vtable for toAWR’
    /appo/tora-2.1.3/src/toawr.cpp:381: undefined reference to `vtable for toAWR’
    tora-toawr.o:/appo/tora-2.1.3/src/toawr.cpp:381: more undefined references to `vtable for toAWR’ follow
    tora-toawr.o: In function `toAWR::tr(char const*, char const*)’:
    /appo/tora-2.1.3/src/toawr.h:57: undefined reference to `toAWR::staticMetaObject’
    collect2: ld returned 1 exit status
    make[3]: *** [tora] Error 1
    make[3]: Leaving directory `/appo/tora-2.1.3/src’
    make[2]: *** [all] Error 2
    make[2]: Leaving directory `/appo/tora-2.1.3/src’
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/appo/tora-2.1.3′
    make: *** [all] Error 2

    1. Ciao Fabio,
      grazie per il tuo commento ! In primis ti dico che ho abbandonato Slackware, dopo 10 anni, a favore di Ubuntu proprio perchè non avevo più voglia di sbattermi con le dipendenze, errori di compilazione, etc etc etc. Prescindendo dalla mia decisione, sembra che l’errore segnalato dipenda dal fatto che non trova la funzione “staticMetaObject” nell’oggetto “toAWR”. Prova a fare una ricerca nei files per vedere se trovi “toAWR” e poi la funzione “staticMetaObject”.

      Michele

      1. Grazie a te per la risposta.
        Io rimango invece testardamente fedele alla Slackware.
        Ti farò sapere se sono riuscito a compilare.

        Fabio

Rispondi

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.